Docker安装提示无供应商可供安装的解决办法

技术宅今天带来的是Docker安装提示无供应商可供安装的解决办法,首先我们定位到错误提示问题: package docker-ce-3:19.03.11-3.el7.x86_64 requires containerd.io >= 1.2.2-3, but none of the providers can be installed

Docker安装提示无供应商可供安装的解决办法

根据提示,就是Docker安装过程中需要的依赖项containerd.io版本 >= 1.2.2-3,既然错误定位到,那么解决方法就油然而生了!

解决办法

进入阿里云镜像地址:https://mirrors.aliyun.com/docker-ce/linux/centos/7/x86_64/edge/Packages/找到我们想要的或者最新的containerd.io包!然后执行以下命令:

yum install -y https://mirrors.aliyun.com/docker-ce/linux/centos/7/x86_64/edge/Packages/containerd.io-1.2.13-3.1.el7.x86_64.rpm

Docker安装提示无供应商可供安装的解决办法

安装完成后再执行以下命令即可:

yum install docker-ce docker-ce-cli containerd.io
技术分享

如何在 Linux 上将 USB 盘格式化为 exFAT

2020-6-9 2:25:59

技术分享

会声会影使用时出现BurnStarR DLL已停止工作如何解决

2020-6-13 19:00:29

    暂无讨论,说说你的看法吧
个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索